What browsers does GoAnimate support?

GoAnimate supports the latest versions of Chrome, Firefox, Safari and Internet Explorer.  The latest version of the Adobe Flash plug-in must also be installed.

NOTE: 8/23/17 Exception and Known Issue:
https://support.goanimate.com/hc/en-us/articles/115004261683

Not sure what version you have? Click here: https://www.whatismybrowser.com/

Have more questions? Submit a request
Follow