GoAnimate System Requirements

Find out what version of operating system and browser you're using here.

Using GoAnimate requires the following hardware, software, and internet access.

Hardware

Any modern computer with at least 8GB of memory running:

  • Windows 7 / SP1 or later (see note #1 below)
  • Mac operating system.

 

Software

One of the following web browsers:

  • Internet Explorer 11 (see note #2 below - must be Windows 8 or higher to create videos)
  • Microsoft Edge
  • Chrome
  • Firefox version 42 or later
  • Safari

 

The Adobe Flash plug-in (to be retired in 2017)


Internet Access

As a web-based service, access to the Internet is required. A specific list of URLs that must be accessible can be found here.

 

Notes

#1 As of 8/29/16, videos hosted on GoAnimate's site can be watched using the HTML5 (non-Flash-based) Video Player with any combination of computer, operating system, and browser listed above. For those using Internet Explorer 11 on a Windows 7 computer, the following message will appear before the video can be played:

"We are optimizing this video to be compatible with your browser. Please wait a few minutes then refresh this page."

If you see this message, you can either wait for the optimization to complete (1 to 5 minutes, generally), or you can switch to the legacy Video Player by clicking on the link outlined in the image below. You'll find it just above the video you are trying to watch.


 

#2 Beginning early 2017, if you are using Internet Explorer 11 to create videos, you will need a computer running Windows 8, at minimum, when using the HTML5 (non-Flash-based) Video Maker that is scheduled to be released at that time. Windows 7, in combination with Internet Explorer 11, will not be supported for creating videos with GoAnimate's HTML5 Video Maker.

 

If you're not sure what version of operating system or browser you're using, find out here!

 

Have more questions? Submit a request
Follow